Login Form

#636 – Survey screen goes blank when additional questions are added

Posted in ‘BF Survey’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Saturday, 30 May 2015 04:31 AEST
OhAlan
Joomla! version: (3.4)

Hi there

I have a survey that loads fine in a tab survey format.

It is comprised entirely of open ended questions in a text format (max 255 characters.)

It loads fine up till 42 questions, then when an additional question is published in the survey, the survey won't load. You can see the survey heading and a rectangular box, but nothing else, just a blank page.

Just wondering what the problem might be and how I could resolve it?

Thanks very much.

Best regards.
Saturday, 30 May 2015 13:44 AEST 5'
Tim
Everything Bundle, BF Quiz Plus 3 Years, BF Survey 12 Months
Try setting error reporting to maximum in your global config, and see if you get an exact error message rather than the white screen of death. Let me know what error you are seeing.
Follow us on twitter http://twitter.com/tamlynsoftware
Saturday, 30 May 2015 18:52 AEST
OhAlan
Hi

No problem. The messages at the top of the screen are as follows:

Notice: Trying to get property of non-object in /home/wisdo10/public_html/components/com_sefadvance/build.php on line 219

Warning: simplexml_load_file() [function.simplexml-load-file]: /home/wisdo10/public_html/components/com_bfsurvey/views/3result/tmpl/form.form.xml:120: parser error : xmlParseEntityRef: no name in /home/wisdo10/public_html/libraries/joomla/form/form.php on line 874

Warning: simplexml_load_file() [function.simplexml-load-file]: ault="Customer Orientation;Financial Orientation;Internal Orientation;Research & in /home/wisdo10/public_html/libraries/joomla/form/form.php on line 874

Warning: simplexml_load_file() [function.simplexml-load-file]: ^ in /home/wisdo10/public_html/libraries/joomla/form/form.php on line 874

The messages in the rectangle are as follows:

Notice: Undefined property: F0FViewHtml::$form in /home/wisdo10/public_html/components/com_bfsurvey/views/3result/tmpl/form.php on line 60

Fatal error: Call to a member function getFieldsets() on a non-object in /home/wisdo10/public_html/components/com_bfsurvey/views/3result/tmpl/form.php on line 60

Thanks.
Sunday, 31 May 2015 16:42 AEST 5'
Tim
Everything Bundle, BF Quiz Plus 3 Years, BF Survey 12 Months
It's that last "Fatal error" that is causing the white screen of death.

Can you post the contents of the file:
/components/com_bfsurvey/views/3result/tmpl/form.form.xml

Feel free to make this a private ticket if you prefer.

regards

Tim
Follow us on twitter http://twitter.com/tamlynsoftware
Sunday, 31 May 2015 17:20 AEST
OhAlan
Hi Tim

No problem. Done. Please refer to Private Ticket #638.

Kind regards
Alan
Monday, 01 June 2015 22:43 AEST 2'
Tim
Everything Bundle, BF Quiz Plus 3 Years, BF Survey 12 Months
Hi Alan,
I've replied in ticket #638.

regards

Tim
Follow us on twitter http://twitter.com/tamlynsoftware
Wednesday, 08 July 2015 14:25 AEST
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.
Go to top