Login Form

#249 – Many bugs

Posted in ‘BF Auction’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Saturday, 07 June 2014 14:04 AEST
QASAdmin
Joomla! version: 2.5.20
BFA+: 1.5.9
Have HTTPS forced on all pages due to CC sales.
Please keep in mind, auction is already live and has bids, so nothing destructive can be done.

Issue 1 (hi-pri): Bid history results in blank page

Issue 2: Date format in FE unresponsive to change. Showing d-m-Y and I need m-d-Y. Does not reflect in FE, only Admin.

Issue 3: Nothing shows up in Sales Log, did on previous versions before end of auction. Changing Display # filter acts like data should be there, as pages (prev, next, end and #s) show, but no data.

Thanks!
Saturday, 07 June 2014 18:29 AEST 5'
Tim
Everything Bundle, BF Quiz Plus 3 Years, BF Survey 12 Months
Hi John,
Regarding the blank page, can you try temporarily setting error reporting to maximum in your global config and see if you get an exact error message instead of a blank page which should help pinpoint the problem.

With regards to the date format, have you set this in your auction menu item and the component options?

The sales log issue I am aware of, I've already fixed in my current dev version and fix will be included in the next version release. I'm not home tonight, but will see what I can do about releasing this update on Monday.

regards

Tim
Follow us on twitter http://twitter.com/tamlynsoftware
Sunday, 08 June 2014 02:08 AEST
QASAdmin
Thanks Tim
Issue 1: Tried with debug, java console, inspect element...it is literally a blank page.
Issue 2: Date format corrected, user error, multiple places to be set. Needed to be set in menu item, I had it in options.
Issue 3: Waiting on fix, thank you.
Sunday, 08 June 2014 08:45 AEST 5'
Tim
Everything Bundle, BF Quiz Plus 3 Years, BF Survey 12 Months
Hi John,
Can you please try the following for issue 1.
Site->Global Configuration
Server tab
error reporting=maximum

See if you then get an exact error message rather than a blank page.

regards

Tim
Follow us on twitter http://twitter.com/tamlynsoftware
Sunday, 08 June 2014 09:08 AEST
QASAdmin
Thanks for the advice Tim. I found the following error reported.
Parse error: syntax error, unexpected 'echo' (T_ECHO), expecting ')' in /home/qasadmin/public_html/components/com_bfauction_plus/views/bidhistory/tmpl/default.php on line 85


Sunday, 08 June 2014 09:27 AEST 5'
Tim
Everything Bundle, BF Quiz Plus 3 Years, BF Survey 12 Months
Hi John,
Thanks for the extra info, I can see what the problem is now.

The fix is to edit the file /components/com_bfauction_plus/views/bidhistory/tmpl/default.php

//line 85
<?php echo $currencySymbolAfter? '':$bfcurrency; ?><?php number_format(echo $row->bid,2); ?>

//change to
<?php echo $currencySymbolAfter? '':$bfcurrency; ?><?php echo number_format($row->bid,2); ?>

This fix will be included in the next version release.

regards

Tim
Follow us on twitter http://twitter.com/tamlynsoftware
Sunday, 08 June 2014 13:45 AEST
QASAdmin
Fixed, thanks TIm!
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.
Go to top